Juniper (JNCIS-SP)
  • 1) Juniper Initial Configuration
  • 2) Juniper VLANs + Inter VLAN Routing + DHCP
    • 2.1) Классическая маршрутизация между VLAN (При помощи роутера)
      • Настройка VLAN'ов на SW-MSK-ARB
      • Настройка VLAN'ов на SW-SPB-NEV
      • Настройка IP-адресации, DHCP и маршрутизации между VLAN'ами
      • Проверка конфигурации
      • Полезные ссылки
    • 2.2) Маршрутизация между VLAN на L3-коммутаторе
  • 3) LAGs + Static Routing (с резервированием) + SysLog + SSH
    • Агрегирование каналов и настройка IP-адресов
    • Статическая маршрутизация с резервированием
    • Настройка доступа к Juniper по SSH
    • SysLog Server
    • Конфигурации Устройств
    • Полезные ссылки
  • 4) Q-in-Q
    • Настройка Q-in-Q
    • Конфигурации устройств
  • 5) MC-LAG (Multi-Chassis LAG) + BFD + IRB
    • MC-LAG
    • Конфигурации устройств
    • Полезные ссылки
  • 6) STP (RSTP/VSTP/MSTP + MVRP)
    • RSTP
    • VSTP
    • MSTP
    • STP Protection
    • Конфигурации устройств
    • Полезные ссылки
  • 7) Basic Routing Concepts
    • Полезные ссылки
  • 8) OSPF
    • 4.1) Смена типов областей и Load Balancing
      • Конфигурации устройств
    • 4.2) Настройка Virtual-Link, OSPF в Broadcast-сетях (Выбор DR и BDR) и OSPF summarization
      • Выбор DR и BDR
      • Настройка Virtual-Link + Route Summarization
      • Конфигурации устройств
    • Примечание (Router-ID)
    • OSPF Database and LSA
    • Полезные ссылки
  • 9) IS-IS
    • Практическая часть
    • Конфигурации устройств
    • Полезные ссылки
  • 10) BGP
    • eBGP
    • Анонсирование первых префиксов
    • iBGP
      • BGP Confederations
      • Атрибут Next-Hop и iBGP
      • BGP Route Reflectors
    • BGP Routing Policies
    • BGP Load Balancing
    • BGP Session Attributes
    • Конфигурации устройств
    • Примечание (Router-ID)
    • Полезные ссылки:
  • 11) MPLS
    • Static LSP
    • LDP
    • RSVP
    • L2/L3 VPN
    • Конфигурации Устройств
    • Полезные ссылки
  • 12) CSPF (Dynamic TE)
    • Настройка
    • Конфигурации устройств
    • Полезные ссылки
  • 13) Tunneling Technologies (IPIP/GRE)
    • Конфигурации устройств
    • Полезные ссылки
  • 14) High Availability
    • Конфигурации устройств
    • Полезные ссылки
  • 15) IPv6
  • Полезные ссылки
Powered by GitBook
On this page
  • IPIP
  • IGP Over GRE
  • IPv6 Over IPv4
  • L2 Over GRE
  • MPLS Over GRE

Was this helpful?

  1. 13) Tunneling Technologies (IPIP/GRE)

Конфигурации устройств

IPIP

system {
    host-name Router-1;
    root-authentication {
        encrypted-password "$1$g0.ilY2l$BWxgrwnnTkf5/ZR3HZpVQ1"; ## SECRET-DATA
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family inet {
                address 192.168.5.1/24;
            }
        }
    }
    ge-0/0/1 {
        unit 0 {
            family inet {
                address 172.16.1.0/31;
            }
        }
    }
}                                       
routing-options {
    router-id 1.1.1.1;
}
protocols {
    ospf {
        area 0.0.0.0 {
            interface ge-0/0/0.0 {
                passive;
            }
            interface ge-0/0/1.0 {
                interface-type p2p;
            }
        }
    }
}
system {
    host-name Site-1;
    root-authentication {
        encrypted-password "$1$g0.ilY2l$BWxgrwnnTkf5/ZR3HZpVQ1"; ## SECRET-DATA
    }
}
chassis {
    fpc 0 {
        pic 0 {
            tunnel-services;
        }
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family inet {
                address 2.2.2.1/30;
            }
        }
    }                                   
    ip-0/0/0 {
        unit 0 {
            tunnel {
                source 2.2.2.1;
                destination 4.4.4.1;
            }
            family inet {
                address 10.10.10.1/24;
            }
        }
    }
    ge-0/0/1 {
        unit 0 {
            family inet {
                address 172.16.1.1/31;
            }
        }
    }
}
routing-options {
    static {
        route 0.0.0.0/0 next-hop 10.10.10.2;
        route 4.4.4.1/32 next-hop 2.2.2.2;
    }
    router-id 1.1.1.2;
}
protocols {
    ospf {
        export static-in-ospf;
        area 0.0.0.0 {
            interface ge-0/0/1.0 {
                interface-type p2p;
            }
            interface ge-0/0/0.0 {
                passive;
            }
        }
    }
}
policy-options {
    policy-statement static-in-ospf {
        from {
            protocol static;
            route-filter 0.0.0.0/0 exact;
        }
        then accept;                    
    }
}
hostname Internet
interface Ethernet0/0
 ip address 2.2.2.2 255.255.255.252
 !
interface Ethernet0/1
 ip address 4.4.4.2 255.255.255.252
 !
system {
    host-name Site-2;
    root-authentication {
        encrypted-password "$1$g0.ilY2l$BWxgrwnnTkf5/ZR3HZpVQ1"; ## SECRET-DATA
    }
}
chassis {
    aggregated-devices {
        ethernet {
            device-count 1;
        }
    }
    fpc 0 {
        pic 0 {
            tunnel-services;
        }
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {                        
            family inet {
                address 4.4.4.1/30;
            }
        }
    }
    ip-0/0/0 {
        unit 0 {
            tunnel {
                source 4.4.4.1;
                destination 2.2.2.1;
            }
            family inet {
                address 10.10.10.2/24;
            }
        }
    }
    ge-0/0/1 {
        unit 0 {
            family inet {
                address 172.16.2.1/31;
            }
        }
    }                                   
}
routing-options {
    static {
        route 0.0.0.0/0 next-hop 10.10.10.1;
        route 2.2.2.1/32 next-hop 4.4.4.2;
    }
    router-id 2.2.2.22;
}
protocols {
    ospf {
        export static-in-ospf;
        area 0.0.0.0 {
            interface ge-0/0/1.0 {
                interface-type p2p;
            }
            interface ge-0/0/0.0 {
                passive;
            }
        }
    }
}
policy-options {
    policy-statement static-in-ospf {   
        from {
            protocol static;
            route-filter 0.0.0.0/0 exact;
        }
        then accept;
    }
}
system {
    host-name Router-2;
    root-authentication {
        encrypted-password "$1$g0.ilY2l$BWxgrwnnTkf5/ZR3HZpVQ1"; ## SECRET-DATA
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family inet {
                address 192.168.6.1/24;
            }
        }
    }
    ge-0/0/1 {
        unit 0 {
            family inet {
                address 172.16.2.0/31;
            }
        }
    }
}                                       
routing-options {
    router-id 2.2.2.2;
}
protocols {
    ospf {
        area 0.0.0.0 {
            interface ge-0/0/0.0 {
                passive;
            }
            interface ge-0/0/1.0 {
                interface-type p2p;
            }
        }
    }
}

Далее будут приводится только настройки тех устройств, конфигурация которых изменилась, относительно предыдущего пункта.

IGP Over GRE

system {
    host-name Site-1;
    root-authentication {
        encrypted-password "$1$g0.ilY2l$BWxgrwnnTkf5/ZR3HZpVQ1"; ## SECRET-DATA
    }
}
chassis {
    fpc 0 {
        pic 0 {
            tunnel-services;
        }
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family inet {
                address 2.2.2.1/30;
            }
        }
    }                                   
    gr-0/0/0 {
        unit 0 {
            tunnel {
                source 2.2.2.1;
                destination 4.4.4.1;
            }
            family inet {
                address 10.10.10.1/24;
            }
        }
    }
    ge-0/0/1 {
        unit 0 {
            family inet {
                address 172.16.1.1/31;
            }
        }
    }
}
routing-options {
    static {
        route 4.4.4.1/32 next-hop 2.2.2.2;
    }                                   
    router-id 1.1.1.2;
}
protocols {
    ospf {
        area 0.0.0.0 {
            interface ge-0/0/1.0 {
                interface-type p2p;
            }
            interface ge-0/0/0.0 {
                passive;
            }
            interface gr-0/0/0.0 {
                interface-type p2p;
            }
        }
    }
}
system {
    host-name Site-2;
    root-authentication {
        encrypted-password "$1$g0.ilY2l$BWxgrwnnTkf5/ZR3HZpVQ1"; ## SECRET-DATA
    }
}
chassis {
    fpc 0 {
        pic 0 {
            tunnel-services;
        }
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {                        
            family inet {
                address 4.4.4.1/30;
            }
        }
    }
    gr-0/0/0 {
        unit 0 {
            tunnel {
                source 4.4.4.1;
                destination 2.2.2.1;
            }
            family inet {
                address 10.10.10.2/24;
            }
        }
    }
    ge-0/0/1 {
        unit 0 {
            family inet {
                address 172.16.2.1/31;
            }
        }
    }                                   
}
routing-options {
    static {
        route 2.2.2.1/32 next-hop 4.4.4.2;
    }
    router-id 2.2.2.22;
}
protocols {
    ospf {
        area 0.0.0.0 {
            interface ge-0/0/1.0 {
                interface-type p2p;
            }
            interface ge-0/0/0.0 {
                passive;
            }
            interface gr-0/0/0.0 {
                interface-type p2p;
            }
        }
    }
}

IPv6 Over IPv4

system {
    root-authentication {
        encrypted-password "$1$PpJTV8Ab$qCsraT99bfEvcqaypRFFw."; ## SECRET-DATA
    }
    host-name Site-1;
}
chassis {
    fpc 0 {
        pic 0 {
            tunnel-services;
        }
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family inet {
                address 2.2.2.1/30;
            }
        }
    }                                   
    gr-0/0/0 {
        unit 0 {
            tunnel {
                source 2.2.2.1;
                destination 4.4.4.1;
            }
            family inet6 {
                address 2000::1/64;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet6 {
                address 2001::1/64;
            }                           
        }
    }
}
routing-options {
    static {
        route 4.4.4.1/32 next-hop 2.2.2.2;
    }
    router-id 1.1.1.2;
}
protocols {
    ospf3 {
        area 0.0.0.0 {
            interface lo0.0 {
                passive;
            }
            interface gr-0/0/0.0 {
                interface-type p2p;
            }
        }
    }
}
system {
    root-authentication {
        encrypted-password "$1$PpJTV8Ab$qCsraT99bfEvcqaypRFFw."; ## SECRET-DATA
    }
    host-name Site-2;
}
chassis {
    aggregated-devices {
        ethernet {
            device-count 1;
        }
    }
    fpc 0 {
        pic 0 {
            tunnel-services;
        }
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {                        
            family inet {
                address 4.4.4.1/30;
            }
        }
    }
    gr-0/0/0 {
        unit 0 {
            tunnel {
                source 4.4.4.1;
                destination 2.2.2.1;
            }
            family inet6 {
                address 2000::2/64;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet6 {
                address 2002::1/64;
            }
        }
    }
}
routing-options {
    static {
        route 2.2.2.1/32 next-hop 4.4.4.2;
    }
    router-id 2.2.2.22;
}
protocols {
    ospf3 {
        area 0.0.0.0 {
            interface gr-0/0/0.0 {
                interface-type p2p;
            }
            interface lo0.0 {
                passive;
            }
        }
    }
}

L2 Over GRE

system {
    host-name Router-1;
    root-authentication {
        encrypted-password "$1$g0.ilY2l$BWxgrwnnTkf5/ZR3HZpVQ1"; ## SECRET-DATA
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family bridge {
                interface-mode access;
                vlan-id 10;
            }
        }
    }
    ge-0/0/1 {
        unit 0 {
            family bridge {
                interface-mode trunk;
                vlan-id-list 10;
            }
        }                               
    }
}
bridge-domains {
    v10 {
        vlan-id 10;
    }
}
system {
    root-authentication {
        encrypted-password "$1$g0.ilY2l$BWxgrwnnTkf5/ZR3HZpVQ1"; ## SECRET-DATA
    }
    host-name Site-1;
}
chassis {
    fpc 0 {
        pic 0 {
            tunnel-services;
        }
    }
    network-services enhanced-ip;
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family inet {
                address 2.2.2.1/30;
            }
        }
    }                                   
    gr-0/0/0 {
        unit 0 {
            tunnel {
                source 2.2.2.1;
                destination 4.4.4.1;
            }
            family bridge {
                interface-mode trunk;
                vlan-id-list 10;
            }
        }
    }
    ge-0/0/1 {
        unit 0 {
            family bridge {
                interface-mode trunk;
                vlan-id-list 10;
            }
        }
    }
}
routing-options {
    static {                            
        route 4.4.4.1/32 next-hop 2.2.2.2;
    }
}
routing-instances {
    v10 {
        instance-type virtual-switch;
        interface gr-0/0/0.0;
        interface ge-0/0/1.0;
        bridge-domains {
            v10 {
                vlan-id 10;
            }
        }
    }
}
hostname Internet
interface Ethernet0/0
 ip address 2.2.2.2 255.255.255.252
 !
interface Ethernet0/1
 ip address 4.4.4.2 255.255.255.252
 !
system {
    root-authentication {
        encrypted-password "$1$g0.ilY2l$BWxgrwnnTkf5/ZR3HZpVQ1"; ## SECRET-DATA
    }
    host-name Site-2;
}
chassis {
    fpc 0 {
        pic 0 {
            tunnel-services;
        }
    }
    network-services enhanced-ip;
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family inet {
                address 4.4.4.1/30;
            }
        }
    }                                   
    gr-0/0/0 {
        unit 0 {
            tunnel {
                source 4.4.4.1;
                destination 2.2.2.1;
            }
            family bridge {
                interface-mode trunk;
                vlan-id-list 10;
            }
        }
    }
    ge-0/0/1 {
        unit 0 {
            family bridge {
                interface-mode trunk;
                vlan-id-list 10;
            }
        }
    }
}
routing-options {
    static {                            
        route 2.2.2.1/32 next-hop 4.4.4.2;
    }
}
routing-instances {
    v10 {
        instance-type virtual-switch;
        interface gr-0/0/0.0;
        interface ge-0/0/1.0;
        bridge-domains {
            v10 {
                vlan-id 10;
            }
        }
    }
}
system {
    host-name Router-2;
    root-authentication {
        encrypted-password "$1$g0.ilY2l$BWxgrwnnTkf5/ZR3HZpVQ1"; ## SECRET-DATA
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family bridge {
                interface-mode access;
                vlan-id 10;
            }
        }
    }
    ge-0/0/1 {
        unit 0 {
            family bridge {
                interface-mode trunk;
                vlan-id-list 10;
            }
        }                               
    }
}
bridge-domains {
    v10 {
        vlan-id 10;
    }
}

MPLS Over GRE

system {
    host-name Router-1;
    root-authentication {
        encrypted-password "$1$PpJTV8Ab$qCsraT99bfEvcqaypRFFw."; ## SECRET-DATA
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family inet {
                address 192.168.5.1/24;
            }
            family mpls;
        }
    }
    ge-0/0/1 {
        unit 0 {
            family inet {
                address 172.16.1.0/31;
            }
            family mpls;
        }                               
    }
    lo0 {
        unit 0 {
            family inet {
                address 1.1.1.1/32;
            }
            family mpls;
        }
    }
}
routing-options {
    router-id 1.1.1.1;
}
protocols {
    ospf {
        area 0.0.0.0 {
            interface ge-0/0/0.0 {
                passive;
            }
            interface ge-0/0/1.0 {
                interface-type p2p;
            }
            interface lo0.0 {           
                passive;
            }
        }
    }
    ldp {
        interface all;
    }
}
system {
    root-authentication {
        encrypted-password "$1$g0.ilY2l$BWxgrwnnTkf5/ZR3HZpVQ1"; ## SECRET-DATA
    }
    host-name Site-1;
}
chassis {
    fpc 0 {
        pic 0 {
            tunnel-services;
        }
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family inet {
                address 2.2.2.1/30;
            }
        }
    }
    gr-0/0/0 {                          
        unit 0 {
            tunnel {
                source 2.2.2.1;
                destination 4.4.4.1;
            }
            family inet {
                address 10.10.10.1/24;
            }
            family mpls;
        }
    }
    ge-0/0/1 {
        unit 0 {
            family inet {
                address 172.16.1.1/31;
            }
            family mpls;
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 1.1.1.2/32;     
            }
            family mpls;
        }
    }
}
routing-options {
    static {
        route 4.4.4.1/32 next-hop 2.2.2.2;
    }
    router-id 1.1.1.2;
}
protocols {
    ospf {
        area 0.0.0.0 {
            interface ge-0/0/1.0 {
                interface-type p2p;
            }
            interface ge-0/0/0.0 {
                passive;
            }
            interface gr-0/0/0.0 {
                interface-type p2p;
            }                           
            interface lo0.0 {
                passive;
            }
        }
    }
    ldp {
        interface all;
    }
}
hostname Internet
interface Ethernet0/0
 ip address 2.2.2.2 255.255.255.252
 !
interface Ethernet0/1
 ip address 4.4.4.2 255.255.255.252
 !
system {
    root-authentication {
        encrypted-password "$1$g0.ilY2l$BWxgrwnnTkf5/ZR3HZpVQ1"; ## SECRET-DATA
    }
    host-name Site-2;
}
chassis {
    fpc 0 {
        pic 0 {
            tunnel-services;
        }
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family inet {
                address 4.4.4.1/30;
            }
        }
    }
    gr-0/0/0 {                          
        unit 0 {
            tunnel {
                source 4.4.4.1;
                destination 2.2.2.1;
            }
            family inet {
                address 10.10.10.2/24;
            }
            family mpls;
        }
    }
    ge-0/0/1 {
        unit 0 {
            family inet {
                address 172.16.2.1/31;
            }
            family mpls;
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 2.2.2.22/32;    
            }
            family mpls;
        }
    }
}
routing-options {
    static {
        route 2.2.2.1/32 next-hop 4.4.4.2;
    }
    router-id 2.2.2.22;
}
protocols {
    ospf {
        area 0.0.0.0 {
            interface ge-0/0/1.0 {
                interface-type p2p;
            }
            interface ge-0/0/0.0 {
                passive;
            }
            interface gr-0/0/0.0 {
                interface-type p2p;
            }                           
            interface lo0.0 {
                passive;
            }
        }
    }
    ldp {
        interface all;
    }
}
system {
    host-name Router-2;
    root-authentication {
        encrypted-password "$1$WWHrtbvC$LheWkevlddegEGfLxNNYi0"; ## SECRET-DATA
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family inet {
                address 192.168.6.1/24;
            }
            family mpls;
        }
    }
    ge-0/0/1 {
        unit 0 {
            family inet {
                address 172.16.2.0/31;
            }
            family mpls;
        }                               
    }
    lo0 {
        unit 0 {
            family inet {
                address 2.2.2.2/32;
            }
            family mpls;
        }
    }
}
routing-options {
    router-id 2.2.2.2;
}
protocols {
    ospf {
        area 0.0.0.0 {
            interface ge-0/0/0.0 {
                passive;
            }
            interface ge-0/0/1.0 {
                interface-type p2p;
            }
            interface lo0.0 {           
                passive;
            }
        }
    }
    ldp {
        interface all;
    }
}
Previous13) Tunneling Technologies (IPIP/GRE)NextПолезные ссылки

Last updated 4 years ago

Was this helpful?