Juniper (JNCIS-SP)
  • 1) Juniper Initial Configuration
  • 2) Juniper VLANs + Inter VLAN Routing + DHCP
    • 2.1) Классическая маршрутизация между VLAN (При помощи роутера)
      • Настройка VLAN'ов на SW-MSK-ARB
      • Настройка VLAN'ов на SW-SPB-NEV
      • Настройка IP-адресации, DHCP и маршрутизации между VLAN'ами
      • Проверка конфигурации
      • Полезные ссылки
    • 2.2) Маршрутизация между VLAN на L3-коммутаторе
  • 3) LAGs + Static Routing (с резервированием) + SysLog + SSH
    • Агрегирование каналов и настройка IP-адресов
    • Статическая маршрутизация с резервированием
    • Настройка доступа к Juniper по SSH
    • SysLog Server
    • Конфигурации Устройств
    • Полезные ссылки
  • 4) Q-in-Q
    • Настройка Q-in-Q
    • Конфигурации устройств
  • 5) MC-LAG (Multi-Chassis LAG) + BFD + IRB
    • MC-LAG
    • Конфигурации устройств
    • Полезные ссылки
  • 6) STP (RSTP/VSTP/MSTP + MVRP)
    • RSTP
    • VSTP
    • MSTP
    • STP Protection
    • Конфигурации устройств
    • Полезные ссылки
  • 7) Basic Routing Concepts
    • Полезные ссылки
  • 8) OSPF
    • 4.1) Смена типов областей и Load Balancing
      • Конфигурации устройств
    • 4.2) Настройка Virtual-Link, OSPF в Broadcast-сетях (Выбор DR и BDR) и OSPF summarization
      • Выбор DR и BDR
      • Настройка Virtual-Link + Route Summarization
      • Конфигурации устройств
    • Примечание (Router-ID)
    • OSPF Database and LSA
    • Полезные ссылки
  • 9) IS-IS
    • Практическая часть
    • Конфигурации устройств
    • Полезные ссылки
  • 10) BGP
    • eBGP
    • Анонсирование первых префиксов
    • iBGP
      • BGP Confederations
      • Атрибут Next-Hop и iBGP
      • BGP Route Reflectors
    • BGP Routing Policies
    • BGP Load Balancing
    • BGP Session Attributes
    • Конфигурации устройств
    • Примечание (Router-ID)
    • Полезные ссылки:
  • 11) MPLS
    • Static LSP
    • LDP
    • RSVP
    • L2/L3 VPN
    • Конфигурации Устройств
    • Полезные ссылки
  • 12) CSPF (Dynamic TE)
    • Настройка
    • Конфигурации устройств
    • Полезные ссылки
  • 13) Tunneling Technologies (IPIP/GRE)
    • Конфигурации устройств
    • Полезные ссылки
  • 14) High Availability
    • Конфигурации устройств
    • Полезные ссылки
  • 15) IPv6
  • Полезные ссылки
Powered by GitBook
On this page
  • Active-Standby
  • Active-Active
  • Router

Was this helpful?

  1. 5) MC-LAG (Multi-Chassis LAG) + BFD + IRB

Конфигурации устройств

Active-Standby

system {
    host-name CE1;
    root-authentication {
        encrypted-password "$6$EJGUsxd0$yp81.o/VmH/WKBmbVO5cYauNKq5L2nhLXcwAybkM2NgWBDc.4jeEOQU/ZHY4DawJobAlRSh00Z6E4/Wp3IXtd0"; ## SECRET-DATA
    }
}
chassis {
    aggregated-devices {
        ethernet {
            device-count 1;
        }
    }
}
interfaces {
    xe-0/0/0 {
        unit 0 {
            family ethernet-switching {
                interface-mode access;
                vlan {
                    members 10;
                }                       
            }
        }
    }
    xe-0/0/1 {
        gigether-options {
            802.3ad ae0;
        }
    }
    xe-0/0/2 {
        gigether-options {
            802.3ad ae0;
        }
    }
    ae0 {
        aggregated-ether-options {
            lacp {
                active;
                periodic fast;
            }
        }
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;   
                vlan {
                    members 10;
                }
            }
        }
    }
    em1 {
        unit 0 {
            family inet {
                address 169.254.0.2/24;
            }
        }
    }
}
vlans {
    v10 {
        vlan-id 10;
    }
}
system {
    host-name Active-PE1;
    root-authentication {
        encrypted-password "$1$9oNcYOOe$wE9iwxzYopFtxwpTfn6jH1"; ## SECRET-DATA
    }
}
chassis {
    aggregated-devices {
        ethernet {
            device-count 5;
        }
    }
}
interfaces {
    ge-0/0/1 {
        gigether-options {
            802.3ad ae1;
        }
    }
    ge-0/0/3 {
        gigether-options {
            802.3ad ae0;                
        }
    }
    ge-0/0/4 {
        gigether-options {
            802.3ad ae0;
        }
    }
    ae0 {
        flexible-vlan-tagging;
        encapsulation flexible-ethernet-services;
        aggregated-ether-options {
            lacp {
                active;
                periodic fast;
            }
        }
        unit 0 {
            vlan-id 4000;
            family inet {
                address 192.168.1.0/31;
            }
        }
        unit 10 {                       
            family bridge {
                interface-mode trunk;
                vlan-id-list 10;
            }
        }
    }
    ae1 {
        flexible-vlan-tagging;
        encapsulation flexible-ethernet-services;
        aggregated-ether-options {
            lacp {
                active;
                periodic fast;
                system-id aa:bb:cc:dd:ee:ff;
                admin-key 1;
            }
            mc-ae {
                mc-ae-id 1;
                redundancy-group 1;
                chassis-id 0;
                mode active-standby;
                status-control active;
            }                           
        }
        unit 10 {
            family bridge {
                interface-mode trunk;
                vlan-id-list 10;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 10.0.0.1/32;
            }
        }
    }
}
protocols {
    ospf {
        area 0.0.0.0 {
            interface lo0.0 {
                passive;
            }
            interface ae0.0 {           
                interface-type p2p;
            }
        }
    }
    iccp {
        local-ip-addr 10.0.0.1;
        peer 10.0.0.2 {
            redundancy-group-id-list 1;
            liveness-detection {
                minimum-interval 1000;
                multiplier 3;
            }
        }
    }
}
bridge-domains {
    v10 {
        vlan-id 10;
    }
}
switch-options {
    service-id 1;
}                                       
system {
    host-name Standby-PE2;
    root-authentication {
        encrypted-password "$1$9oNcYOOe$wE9iwxzYopFtxwpTfn6jH1"; ## SECRET-DATA
    }
}
chassis {
    aggregated-devices {
        ethernet {
            device-count 5;
        }
    }
}
interfaces {
    ge-0/0/0 {
        flexible-vlan-tagging;
        encapsulation flexible-ethernet-services;
        unit 10 {
            family bridge {
                interface-mode trunk;
                vlan-id-list 10;
            }                           
        }
    }
    ge-0/0/2 {
        gigether-options {
            802.3ad ae1;
        }
    }
    ge-0/0/3 {
        gigether-options {
            802.3ad ae0;
        }
    }
    ge-0/0/4 {
        gigether-options {
            802.3ad ae0;
        }
    }
    ae0 {
        flexible-vlan-tagging;
        encapsulation flexible-ethernet-services;
        aggregated-ether-options {
            lacp {
                active;                 
                periodic fast;
            }
        }
        unit 0 {
            vlan-id 4000;
            family inet {
                address 192.168.1.1/31;
            }
        }
        unit 10 {
            family bridge {
                interface-mode trunk;
                vlan-id-list 10;
            }
        }
    }
    ae1 {
        flexible-vlan-tagging;
        encapsulation flexible-ethernet-services;
        aggregated-ether-options {
            lacp {
                active;
                periodic fast;          
                system-id aa:bb:cc:dd:ee:ff;
                admin-key 1;
            }
            mc-ae {
                mc-ae-id 1;
                redundancy-group 1;
                chassis-id 1;
                mode active-standby;
                status-control standby;
            }
        }
        unit 10 {
            family bridge {
                interface-mode trunk;
                vlan-id-list 10;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 10.0.0.2/32;
            }                           
        }
    }
}
protocols {
    ospf {
        area 0.0.0.0 {
            interface lo0.0 {
                passive;
            }
            interface ae0.0 {
                interface-type p2p;
            }
        }
    }
    iccp {
        local-ip-addr 10.0.0.2;
        peer 10.0.0.1 {
            redundancy-group-id-list 1;
            liveness-detection {
                minimum-interval 1000;
                multiplier 3;
            }
        }                               
    }
}
bridge-domains {
    v10 {
        vlan-id 10;
    }
}
switch-options {
    service-id 1;
}

Active-Active

system {
    host-name CE2;
    root-authentication {
        encrypted-password "$6$EJGUsxd0$yp81.o/VmH/WKBmbVO5cYauNKq5L2nhLXcwAybkM2NgWBDc.4jeEOQU/ZHY4DawJobAlRSh00Z6E4/Wp3IXtd0"; ## SECRET-DATA
    }
}
chassis {
    aggregated-devices {
        ethernet {
            device-count 1;
        }
    }
}
interfaces {
    xe-0/0/0 {
        unit 0 {
            family ethernet-switching {
                interface-mode access;
                vlan {
                    members 10;
                }                       
            }
        }
    }
    xe-0/0/1 {
        gigether-options {
            802.3ad ae0;
        }
    }
    xe-0/0/2 {
        gigether-options {
            802.3ad ae0;
        }
    }
    ae0 {
        aggregated-ether-options {
            lacp {
                active;
                periodic fast;
            }
        }
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;   
                vlan {
                    members 10;
                }
            }
        }
    }
    em1 {
        unit 0 {
            family inet {
                address 169.254.0.2/24;
            }
        }
    }
}
vlans {
    v10 {
        vlan-id 10;
    }
}
system {
    host-name Active-PE3;
    root-authentication {
        encrypted-password "$6$EJGUsxd0$yp81.o/VmH/WKBmbVO5cYauNKq5L2nhLXcwAybkM2NgWBDc.4jeEOQU/ZHY4DawJobAlRSh00Z6E4/Wp3IXtd0"; ## SECRET-DATA
    }
}
chassis {
    aggregated-devices {
        ethernet {
            device-count 5;
        }
    }
}
interfaces {
    xe-0/0/1 {
        gigether-options {
            802.3ad ae1;
        }
    }
    xe-0/0/3 {
        gigether-options {              
            802.3ad ae0;
        }
    }
    xe-0/0/4 {
        gigether-options {
            802.3ad ae0;
        }
    }
    ae0 {
        aggregated-ether-options {
            lacp {
                active;
                periodic fast;
            }
        }
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;
                vlan {
                    members [ 10 4000 ];
                }
            }
        }                               
    }
    ae1 {
        aggregated-ether-options {
            lacp {
                active;
                periodic fast;
                system-id ff:ee:dd:cc:bb:aa;
                admin-key 1;
            }
            mc-ae {
                mc-ae-id 1;
                redundancy-group 1;
                chassis-id 0;
                mode active-active;
                status-control active;
            }
        }
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;
                vlan {
                    members 10;
                }                       
            }
        }
    }
    em1 {
        unit 0 {
            family inet {
                address 169.254.0.2/24;
            }
        }
    }
    irb {
        unit 4000 {
            family inet {
                address 192.168.0.1/24;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 10.0.0.3/32;
            }
        }                               
    }
}
multi-chassis {
    multi-chassis-protection 10.0.0.4 {
        interface ae0;
    }
}
protocols {
    ospf {
        area 0.0.0.0 {
            interface lo0.0 {
                passive;
            }
            interface irb.4000;
        }
    }
    iccp {
        local-ip-addr 10.0.0.3;
        peer 10.0.0.4 {
            redundancy-group-id-list 1;
            liveness-detection {
                minimum-interval 1000;
                multiplier 3;           
            }
        }
    }
}
switch-options {
    service-id 1;
}
vlans {
    mgmt {
        vlan-id 4000;
        l3-interface irb.4000;
    }
    v10 {
        vlan-id 10;
    }
}
system {
    host-name Active-PE4;
    root-authentication {
        encrypted-password "$6$EJGUsxd0$yp81.o/VmH/WKBmbVO5cYauNKq5L2nhLXcwAybkM2NgWBDc.4jeEOQU/ZHY4DawJobAlRSh00Z6E4/Wp3IXtd0"; ## SECRET-DATA
    }
}
chassis {
    aggregated-devices {
        ethernet {
            device-count 5;
        }
    }
}
interfaces {
    xe-0/0/1 {
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;
                vlan {
                    members 10;
                }                       
            }
        }
    }
    xe-0/0/2 {
        gigether-options {
            802.3ad ae1;
        }
    }
    xe-0/0/3 {
        gigether-options {
            802.3ad ae0;
        }
    }
    xe-0/0/4 {
        gigether-options {
            802.3ad ae0;
        }
    }
    ae0 {
        aggregated-ether-options {
            lacp {
                active;
                periodic fast;          
            }
        }
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;
                vlan {
                    members [ 10 4000 ];
                }
            }
        }
    }
    ae1 {
        aggregated-ether-options {
            lacp {
                active;
                periodic fast;
                system-id ff:ee:dd:cc:bb:aa;
                admin-key 1;
            }
            mc-ae {
                mc-ae-id 1;
                redundancy-group 1;
                chassis-id 1;           
                mode active-active;
                status-control standby;
            }
        }
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;
                vlan {
                    members 10;
                }
            }
        }
    }
    em1 {
        unit 0 {
            family inet {
                address 169.254.0.2/24;
            }
        }
    }
    irb {
        unit 4000 {
            family inet {               
                address 192.168.0.2/24;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 10.0.0.4/32;
            }
        }
    }
}
multi-chassis {
    multi-chassis-protection 10.0.0.3 {
        interface ae0;
    }
}
protocols {
    ospf {
        area 0.0.0.0 {
            interface lo0.0 {
                passive;
            }                           
            interface irb.4000;
        }
    }
    iccp {
        local-ip-addr 10.0.0.4;
        peer 10.0.0.3 {
            redundancy-group-id-list 1;
            liveness-detection {
                minimum-interval 1000;
                multiplier 3;
            }
        }
    }
}
switch-options {
    service-id 1;
}
vlans {
    mgmt {
        vlan-id 4000;
        l3-interface irb.4000;
    }
    v10 {                               
        vlan-id 10;
    }
}

Router

Router
system {
    host-name Router;
    root-authentication {
        encrypted-password "$1$Q9Cd/oyO$Q0ZJz5hEqPB/NQyuIOwqb1"; ## SECRET-DATA
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family bridge {
                interface-mode trunk;
                vlan-id-list 10;
            }
        }
    }
    ge-0/0/1 {
        unit 0 {
            family bridge {
                interface-mode trunk;
                vlan-id-list 10;
            }
        }                               
    }
    irb {
        unit 10 {
            family inet {
                address 8.8.8.1/24;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 50.0.0.1/32;
            }
        }
    }
}
bridge-domains {
    v10 {
        vlan-id 10;
        routing-interface irb.10;
    }
}
PreviousMC-LAGNextПолезные ссылки

Last updated 4 years ago

Was this helpful?