Juniper (JNCIS-SP)
  • 1) Juniper Initial Configuration
  • 2) Juniper VLANs + Inter VLAN Routing + DHCP
    • 2.1) Классическая маршрутизация между VLAN (При помощи роутера)
      • Настройка VLAN'ов на SW-MSK-ARB
      • Настройка VLAN'ов на SW-SPB-NEV
      • Настройка IP-адресации, DHCP и маршрутизации между VLAN'ами
      • Проверка конфигурации
      • Полезные ссылки
    • 2.2) Маршрутизация между VLAN на L3-коммутаторе
  • 3) LAGs + Static Routing (с резервированием) + SysLog + SSH
    • Агрегирование каналов и настройка IP-адресов
    • Статическая маршрутизация с резервированием
    • Настройка доступа к Juniper по SSH
    • SysLog Server
    • Конфигурации Устройств
    • Полезные ссылки
  • 4) Q-in-Q
    • Настройка Q-in-Q
    • Конфигурации устройств
  • 5) MC-LAG (Multi-Chassis LAG) + BFD + IRB
    • MC-LAG
    • Конфигурации устройств
    • Полезные ссылки
  • 6) STP (RSTP/VSTP/MSTP + MVRP)
    • RSTP
    • VSTP
    • MSTP
    • STP Protection
    • Конфигурации устройств
    • Полезные ссылки
  • 7) Basic Routing Concepts
    • Полезные ссылки
  • 8) OSPF
    • 4.1) Смена типов областей и Load Balancing
      • Конфигурации устройств
    • 4.2) Настройка Virtual-Link, OSPF в Broadcast-сетях (Выбор DR и BDR) и OSPF summarization
      • Выбор DR и BDR
      • Настройка Virtual-Link + Route Summarization
      • Конфигурации устройств
    • Примечание (Router-ID)
    • OSPF Database and LSA
    • Полезные ссылки
  • 9) IS-IS
    • Практическая часть
    • Конфигурации устройств
    • Полезные ссылки
  • 10) BGP
    • eBGP
    • Анонсирование первых префиксов
    • iBGP
      • BGP Confederations
      • Атрибут Next-Hop и iBGP
      • BGP Route Reflectors
    • BGP Routing Policies
    • BGP Load Balancing
    • BGP Session Attributes
    • Конфигурации устройств
    • Примечание (Router-ID)
    • Полезные ссылки:
  • 11) MPLS
    • Static LSP
    • LDP
    • RSVP
    • L2/L3 VPN
    • Конфигурации Устройств
    • Полезные ссылки
  • 12) CSPF (Dynamic TE)
    • Настройка
    • Конфигурации устройств
    • Полезные ссылки
  • 13) Tunneling Technologies (IPIP/GRE)
    • Конфигурации устройств
    • Полезные ссылки
  • 14) High Availability
    • Конфигурации устройств
    • Полезные ссылки
  • 15) IPv6
  • Полезные ссылки
Powered by GitBook
On this page
  • AS и Site
  • Core

Was this helpful?

  1. 11) MPLS

Конфигурации Устройств

AS и Site

system {
    host-name AS400;
    root-authentication {
        encrypted-password "$1$WkjAUkd4$d311x1Zg07TkbMyqK7g8P."; ## SECRET-DATA
    }
}
interfaces {
    ge-0/0/2 {
        flexible-vlan-tagging;
        native-vlan-id 4094;
        encapsulation flexible-ethernet-services;
        unit 0 {
            vlan-id 4094;
            family inet {
                address 40.0.0.2/31;
            }
        }
        unit 500 {
            vlan-id 500;
            family inet {
                address 10.0.0.1/24;
            }                           
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 140.0.0.1/32;
            }
        }
    }
}
routing-options {
    aggregate {
        route 140.0.0.0/16;
    }
    autonomous-system 400;
}
protocols {
    bgp {
        export export-BGP;
        group eBGP {
            type external;
            neighbor 40.0.0.3 {
                peer-as 250;            
            }
        }
    }
}
policy-options {
    policy-statement export-BGP {
        term Aggregate {
            from {
                protocol aggregate;
                route-filter 140.0.0.0/16 exact;
            }
            then accept;
        }
        term BGP {
            from protocol bgp;
            then accept;
        }
        then reject;
    }
}
system {
    host-name AS600;
    root-authentication {
        encrypted-password "$1$WkjAUkd4$d311x1Zg07TkbMyqK7g8P."; ## SECRET-DATA
    }
}
interfaces {
    ge-0/0/3 {
        flexible-vlan-tagging;
        native-vlan-id 4094;
        encapsulation flexible-ethernet-services;
        unit 0 {
            vlan-id 4094;
            family inet {
                address 60.0.0.0/31;
            }
        }
        unit 500 {
            vlan-id 500;
            family inet {
                address 10.0.0.2/24;
            }                           
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 160.0.0.1/32;
            }
        }
    }
}
routing-options {
    aggregate {
        route 160.0.0.0/16;
    }
    autonomous-system 600;
}
protocols {
    bgp {
        export export-BGP;
        group eBGP {
            type external;
            neighbor 60.0.0.1 {
                peer-as 250;            
            }
        }
    }
}
policy-options {
    policy-statement export-BGP {
        term Aggregate {
            from {
                protocol aggregate;
                route-filter 160.0.0.0/16 exact;
            }
            then accept;
        }
        term BGP {
            from protocol bgp;
            then accept;
        }
        then reject;
    }
}
system {
    host-name Site1;
    root-authentication {
        encrypted-password "$1$D04Hyvlf$3YmHgm40cCPxwcVzVBWop/"; ## SECRET-DATA
    }
}
interfaces {
    ge-0/0/9 {
        flexible-vlan-tagging;
        native-vlan-id 4094;
        encapsulation flexible-ethernet-services;
        unit 0 {
            vlan-id 500;
            family inet {
                address 10.0.0.1/24;
            }
        }
        unit 100 {
            vlan-id 4094;
            family inet {
                address 172.16.0.0/31;
            }                           
        }
        unit 250 {
            vlan-id 250;
            family inet {
                address 10.250.0.1/24;
            }
        }
        unit 2500 {
            vlan-id 2500;
            family inet {
                address 10.10.10.1/24;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 172.16.1.1/24;
            }
        }
    }
}
protocols {                             
    ospf {
        area 0.0.0.0 {
            interface ge-0/0/9.100 {
                interface-type p2p;
            }
            interface lo0.0 {
                passive;
            }
        }
    }
}
system {
    host-name Site2;
    root-authentication {
        encrypted-password "$1$D04Hyvlf$3YmHgm40cCPxwcVzVBWop/"; ## SECRET-DATA
    }
}
interfaces {
    ge-0/0/9 {
        flexible-vlan-tagging;
        native-vlan-id 4094;
        encapsulation flexible-ethernet-services;
        unit 0 {
            vlan-id 500;
            family inet {
                address 10.0.0.2/24;
            }
        }
        unit 100 {
            vlan-id 4094;
            family inet {
                address 172.16.0.2/31;
            }                           
        }
        unit 250 {
            vlan-id 250;
            family inet {
                address 10.250.0.2/24;
            }
        }
        unit 2500 {
            vlan-id 2500;
            family inet {
                address 10.10.10.2/24;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 172.16.2.1/24;
            }
        }
    }
}
protocols {                             
    ospf {
        area 0.0.0.0 {
            interface ge-0/0/9.100 {
                interface-type p2p;
            }
            interface lo0.0 {
                passive;
            }
        }
    }
}
system {
    host-name Site3;
    root-authentication {
        encrypted-password "$1$D04Hyvlf$3YmHgm40cCPxwcVzVBWop/"; ## SECRET-DATA
    }
}
interfaces {
    ge-0/0/9 {
        flexible-vlan-tagging;
        native-vlan-id 4094;
        encapsulation flexible-ethernet-services;
        unit 0 {
            vlan-id 500;
            family inet {
                address 10.0.0.3/24;
            }
        }
        unit 100 {
            vlan-id 4094;
            family inet {
                address 172.16.0.4/31;
            }                           
        }
        unit 250 {
            vlan-id 250;
            family inet {
                address 10.250.0.3/24;
            }
        }
        unit 2500 {
            vlan-id 2500;
            family inet {
                address 10.10.10.3/24;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 172.16.3.1/24;
            }
        }
    }
}
protocols {                             
    ospf {
        area 0.0.0.0 {
            interface ge-0/0/9.100 {
                interface-type p2p;
            }
            interface lo0.0 {
                passive;
            }
        }
    }
}

Core

system {
    host-name RT.MSK.M34;
    root-authentication {
        encrypted-password "$1$yjZyno7x$gXQzjRxiaQILDLVjJ2eqz1"; ## SECRET-DATA
    }
}
interfaces {
    ge-0/0/0 {
        flexible-vlan-tagging;
        native-vlan-id 4094;
        encapsulation flexible-ethernet-services;
        unit 0 {
            vlan-id 4094;
            family inet {
                address 10.0.0.10/31;
            }
            family iso;
            family mpls;
        }
    }
    ge-0/0/1 {
        flexible-vlan-tagging;          
        native-vlan-id 4094;
        encapsulation flexible-ethernet-services;
        unit 0 {
            vlan-id 4094;
            family inet {
                address 10.0.0.4/31;
            }
            family iso;
            family mpls;
        }
    }
    ge-0/0/2 {
        flexible-vlan-tagging;
        native-vlan-id 4094;
        encapsulation flexible-ethernet-services;
        unit 0 {
            vlan-id 4094;
            family inet {
                address 40.0.0.3/31;
            }
            family iso;
        }
        unit 500 {                      
            encapsulation vlan-ccc;
            vlan-id 500;
            family ccc;
        }
    }
    ge-0/0/3 {
        flexible-vlan-tagging;
        native-vlan-id 4094;
        encapsulation flexible-ethernet-services;
        unit 0 {
            vlan-id 4094;
            family inet {
                address 10.0.0.0/31;
            }
            family iso;
            family mpls;
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 192.168.0.1/32;
            }                           
            family iso {
                address 49.0001.1921.6800.0001.00;
            }
            family mpls;
        }
    }
}
routing-options {
    static {
        route 192.168.0.8/32 {
            static-lsp-next-hop M34-LNX;
        }
    }
    router-id 192.168.0.1;
    autonomous-system 250;
}
protocols {
    rsvp {
        interface all;
    }
    mpls {
        path-mtu {
            allow-fragmentation;        
            rsvp mtu-signaling;
        }
        no-cspf;
        label-switched-path M34-LNX {
            to 192.168.0.8;
            corouted-bidirectional;
            bandwidth 150m;
            oam {
                bfd-liveness-detection {
                    minimum-interval 1000;
                    multiplier 3;
                    failure-action teardown;
                }
            }
            ultimate-hop-popping;
            primary l_MIR-s_OBV,LNX;
        }
        path l_MIR-s_OBV,LNX {
            10.0.0.24 loose;
            10.0.0.25 strict;
            10.0.0.27 strict;
        }
        interface all;                  
    }
    bgp {
        export export-BGP;
        group eBGP {
            type external;
            neighbor 40.0.0.2 {
                peer-as 400;
            }
        }
        group iBGP {
            type internal;
            local-address 192.168.0.1;
            family inet {
                any;
            }
            family inet-vpn {
                unicast;
            }
            family l2vpn {
                auto-discovery-only;
                signaling;
            }
            export Next-Hop-Self;       
            neighbor 192.168.0.4;
            neighbor 192.168.0.5;
        }
    }
    isis {
        level 1 disable;
        interface ge-0/0/0.0 {
            point-to-point;
        }
        interface ge-0/0/1.0 {
            point-to-point;
        }
        interface ge-0/0/3.0 {
            point-to-point;
        }
        interface lo0.0;
    }
    ldp {
        interface all;
    }
    l2circuit {
        neighbor 192.168.0.8 {
            interface ge-0/0/2.500 {    
                virtual-circuit-id 1488;
            }
        }
    }
}
policy-options {
    policy-statement Next-Hop-Self {
        from protocol bgp;
        then {
            next-hop self;
        }
    }
    policy-statement export-BGP {
        term Aggregate {
            from {
                protocol aggregate;
                route-filter 250.0.0.0/16 exact;
            }
            then accept;
        }
        term BGP {
            from protocol bgp;
            then accept;                
        }
        then reject;
    }
}
system {
    host-name RT.MSK.M8;
    root-authentication {
        encrypted-password "$1$yjZyno7x$gXQzjRxiaQILDLVjJ2eqz1"; ## SECRET-DATA
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family inet {
                address 10.0.0.11/31;
            }
            family iso;
            family mpls;
        }
    }
    ge-0/0/2 {
        unit 0 {
            family inet {
                address 10.0.0.12/31;
            }
            family iso;                 
            family mpls;
        }
    }
    ge-0/0/4 {
        unit 0 {
            family inet {
                address 10.0.0.20/31;
            }
            family iso;
            family mpls;
        }
    }
    ge-0/0/9 {
        flexible-vlan-tagging;
        native-vlan-id 4094;
        encapsulation flexible-ethernet-services;
        unit 100 {
            vlan-id 4094;
            family inet {
                address 172.16.0.1/31;
            }
        }
        unit 250 {                      
            encapsulation vlan-vpls;
            vlan-id 250;
            family vpls;
        }
        unit 500 {
            encapsulation vlan-vpls;
            vlan-id 500;
            family vpls;
        }
        unit 2500 {
            encapsulation vlan-vpls;
            vlan-id 2500;
            family vpls;
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 192.168.0.2/32;
            }
            family iso {
                address 49.0001.1921.6800.0002.00;
            }                           
        }
    }
}
routing-options {
    router-id 192.168.0.2;
    autonomous-system 250;
}
protocols {
    rsvp {
        interface all;
    }
    mpls {
        interface all;
    }
    bgp {
        group iBGP {
            type internal;
            local-address 192.168.0.2;
            family inet {
                any;
            }
            family inet-vpn {
                unicast;                
            }
            family l2vpn {
                auto-discovery-only;
                signaling;
            }
            neighbor 192.168.0.4;
            neighbor 192.168.0.5;
        }
    }
    isis {
        level 1 disable;
        interface ge-0/0/0.0 {
            point-to-point;
        }
        interface ge-0/0/2.0 {
            point-to-point;
        }
        interface ge-0/0/4.0 {
            point-to-point;
        }
        interface lo0.0;
    }
    ldp {                               
        interface all;
    }
}
policy-options {
    policy-statement L3VPN_BGP-OSPF {
        from protocol bgp;
        then accept;
    }
}
routing-instances {
    L3VPN {
        instance-type vrf;
        interface ge-0/0/9.100;
        route-distinguisher 250:0;
        vrf-target {
            import target:250:500;
            export target:250:500;
        }
        vrf-table-label;
        protocols {
            ospf {
                export L3VPN_BGP-OSPF;
                area 0.0.0.0 {          
                    interface ge-0/0/9.100 {
                        interface-type p2p;
                    }
                }
            }
        }
    }
    kompella-vpls-250 {
        instance-type vpls;
        interface ge-0/0/9.250;
        route-distinguisher 10.250.0.1:1;
        vrf-target target:250:250;
        protocols {
            vpls {
                no-tunnel-services;
                site Sites {
                    site-identifier 1;
                    interface ge-0/0/9.250;
                }
                mac-flush;
            }
        }
    }                                   
    martini-auto {
        instance-type vpls;
        interface ge-0/0/9.2500;
        route-distinguisher 2500:10001;
        l2vpn-id l2vpn-id:2500:100;
        vrf-target target:2500:1001;
        protocols {
            vpls {
                no-tunnel-services;
            }
        }
    }
    vpls-500 {
        instance-type vpls;
        interface ge-0/0/9.500;
        protocols {
            vpls {
                no-tunnel-services;
                vpls-id 500;
                mac-flush;
                neighbor 192.168.0.7 {
                    pseudowire-status-tlv;
                }                       
                neighbor 192.168.0.6 {
                    pseudowire-status-tlv;
                }
            }
        }
    }
}
system {
    host-name RT.MSK.M9;
    root-authentication {
        encrypted-password "$1$yjZyno7x$gXQzjRxiaQILDLVjJ2eqz1"; ## SECRET-DATA
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family inet {
                address 10.0.0.6/31;
            }
            family iso;
            family mpls;
        }
    }
    ge-0/0/1 {
        unit 0 {
            family inet {
                address 10.0.0.5/31;
            }
            family iso;                 
            family mpls;
        }
    }
    ge-0/0/2 {
        unit 0 {
            family inet {
                address 10.0.0.13/31;
            }
            family iso;
            family mpls;
        }
    }
    ge-0/0/3 {
        unit 0 {
            family inet {
                address 10.0.0.14/31;
            }
            family iso;
            family mpls;
        }
    }
    lo0 {
        unit 0 {                        
            family inet {
                address 192.168.0.3/32;
            }
            family iso {
                address 49.0001.1921.6800.0003.00;
            }
        }
    }
}
routing-options {
    router-id 192.168.0.3;
    autonomous-system 250;
}
protocols {
    rsvp {
        interface all;
    }
    mpls {
        interface all;
    }
    bgp {
        group iBGP {
            type internal;              
            local-address 192.168.0.3;
            family inet {
                any;
            }
            family inet-vpn {
                unicast;
            }
            family l2vpn {
                auto-discovery-only;
                signaling;
            }
            neighbor 192.168.0.4;
            neighbor 192.168.0.5;
        }
    }
    isis {
        level 1 disable;
        interface ge-0/0/0.0 {
            point-to-point;
        }
        interface ge-0/0/1.0 {
            point-to-point;
        }                               
        interface ge-0/0/2.0 {
            point-to-point;
        }
        interface ge-0/0/3.0 {
            point-to-point;
        }
        interface lo0.0;
    }
    ldp {
        interface all;
    }
}
system {
    host-name RT.SPB.STL;
    root-authentication {
        encrypted-password "$1$yjZyno7x$gXQzjRxiaQILDLVjJ2eqz1"; ## SECRET-DATA
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family inet {
                address 10.0.0.7/31;
            }
            family iso;
            family mpls;
        }
    }
    ge-0/0/1 {
        unit 0 {
            family inet {
                address 10.0.0.16/31;
            }
            family iso;                 
            family mpls;
        }
    }
    ge-0/0/2 {
        unit 0 {
            family inet {
                address 10.0.0.2/31;
            }
            family iso;
            family mpls;
        }
    }
    ge-0/0/3 {
        unit 0 {
            family inet {
                address 10.0.0.1/31;
            }
            family iso;
            family mpls;
        }
    }
    ge-0/0/4 {
        unit 0 {                        
            family inet {
                address 10.0.0.8/31;
            }
            family iso;
            family mpls;
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 192.168.0.4/32;
            }
            family iso {
                address 49.0001.1921.6800.0004.00;
            }
        }
    }
}
routing-options {
    router-id 192.168.0.4;
    autonomous-system 250;
}
protocols {                             
    rsvp {
        interface all;
    }
    mpls {
        interface all;
    }
    bgp {
        group iBGP {
            type internal;
            local-address 192.168.0.4;
            family inet {
                any;
            }
            family inet-vpn {
                unicast;
            }
            family l2vpn {
                auto-discovery-only;
                signaling;
            }
            cluster 0.0.0.1;
            neighbor 192.168.0.2;
            neighbor 192.168.0.3;       
            neighbor 192.168.0.5;
            neighbor 192.168.0.6;
            neighbor 192.168.0.1;
            neighbor 192.168.0.7;
            neighbor 192.168.0.8;
        }
    }
    isis {
        level 1 disable;
        interface ge-0/0/0.0 {
            point-to-point;
        }
        interface ge-0/0/1.0 {
            point-to-point;
        }
        interface ge-0/0/2.0 {
            point-to-point;
        }
        interface ge-0/0/3.0 {
            point-to-point;
        }
        interface ge-0/0/4.0 {
            point-to-point;             
        }
        interface lo0.0;
    }
    ldp {
        interface all;
    }
}
system {
    host-name RT.SPB.OBV;
    root-authentication {
        encrypted-password "$1$yjZyno7x$gXQzjRxiaQILDLVjJ2eqz1"; ## SECRET-DATA
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family inet {
                address 10.0.0.24/31;
            }
            family iso;
            family mpls;
        }
    }
    ge-0/0/1 {
        unit 0 {
            family inet {
                address 10.0.0.17/31;
            }
            family iso;                 
            family mpls;
        }
    }
    ge-0/0/2 {
        unit 0 {
            family inet {
                address 10.0.0.22/31;
            }
            family iso;
            family mpls;
        }
    }
    ge-0/0/3 {
        unit 0 {
            family inet {
                address 10.0.0.15/31;
            }
            family iso;
            family mpls;
        }
    }
    ge-0/0/4 {
        unit 0 {                        
            family inet {
                address 10.0.0.21/31;
            }
            family iso;
            family mpls;
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 192.168.0.5/32;
            }
            family iso {
                address 49.0001.1921.6800.0005.00;
            }
        }
    }
}
routing-options {
    router-id 192.168.0.5;
    autonomous-system 250;
}
protocols {                             
    rsvp {
        interface all;
    }
    mpls {
        interface all;
    }
    bgp {
        group iBGP {
            type internal;
            local-address 192.168.0.5;
            family inet {
                any;
            }
            family inet-vpn {
                unicast;
            }
            family l2vpn {
                auto-discovery-only;
                signaling;
            }
            cluster 0.0.0.1;
            neighbor 192.168.0.1;
            neighbor 192.168.0.2;       
            neighbor 192.168.0.3;
            neighbor 192.168.0.4;
            neighbor 192.168.0.6;
            neighbor 192.168.0.7;
            neighbor 192.168.0.8;
        }
    }
    isis {
        level 1 disable;
        interface ge-0/0/0.0 {
            point-to-point;
        }
        interface ge-0/0/1.0 {
            point-to-point;
        }
        interface ge-0/0/2.0 {
            point-to-point;
        }
        interface ge-0/0/3.0 {
            point-to-point;
        }
        interface ge-0/0/4.0 {
            point-to-point;             
        }
        interface lo0.0;
    }
    ldp {
        interface all;
    }
}
​​system {
    host-name RT.SPB.MIR;
    root-authentication {
        encrypted-password "$1$yjZyno7x$gXQzjRxiaQILDLVjJ2eqz1"; ## SECRET-DATA
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family inet {
                address 10.0.0.25/31;
            }
            family iso;
            family mpls;
        }
    }
    ge-0/0/1 {
        unit 0 {
            family inet {
                address 10.0.0.26/31;
            }
            family iso;                 
            family mpls;
        }
    }
    ge-0/0/9 {
        flexible-vlan-tagging;
        native-vlan-id 4094;
        encapsulation flexible-ethernet-services;
        unit 100 {
            vlan-id 4094;
            family inet {
                address 172.16.0.5/31;
            }
        }
        unit 250 {
            encapsulation vlan-vpls;
            vlan-id 250;
            family vpls;
        }
        unit 500 {
            encapsulation vlan-vpls;
            vlan-id 500;
            family vpls;
        }                               
        unit 2500 {
            encapsulation vlan-vpls;
            vlan-id 2500;
            family vpls;
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 192.168.0.6/32;
                address 172.16.3.1/24;
            }
            family iso {
                address 49.0001.1921.6800.0006.00;
            }
        }
    }
}
routing-options {
    router-id 192.168.0.6;
    autonomous-system 250;
}
protocols {                             
    rsvp {
        interface all;
    }
    mpls {
        interface all;
    }
    bgp {
        group iBGP {
            type internal;
            local-address 192.168.0.6;
            family inet {
                any;
            }
            family inet-vpn {
                unicast;
            }
            family l2vpn {
                auto-discovery-only;
                signaling;
            }
            neighbor 192.168.0.4;
            neighbor 192.168.0.5;
        }                               
    }
    isis {
        level 1 disable;
        interface ge-0/0/0.0 {
            point-to-point;
        }
        interface ge-0/0/1.0 {
            point-to-point;
        }
        interface lo0.0;
    }
    ldp {
        interface all;
    }
}
policy-options {
    policy-statement L3VPN_BGP-OSPF {
        from protocol bgp;
        then accept;
    }
}
routing-instances {
    L3VPN {                             
        instance-type vrf;
        interface ge-0/0/9.100;
        route-distinguisher 250:0;
        vrf-target {
            import target:250:500;
            export target:250:500;
        }
        vrf-table-label;
        protocols {
            ospf {
                export L3VPN_BGP-OSPF;
                area 0.0.0.0 {
                    interface ge-0/0/9.100 {
                        interface-type p2p;
                    }
                }
            }
        }
    }
    kompella-vpls-250 {
        instance-type vpls;
        interface ge-0/0/9.250;
        route-distinguisher 10.250.0.3:1;
        vrf-target target:250:250;
        protocols {
            vpls {
                no-tunnel-services;
                site Sites {
                    site-identifier 3;
                    interface ge-0/0/9.250;
                }
            }
        }
    }
    martini-auto {
        instance-type vpls;
        interface ge-0/0/9.2500;
        route-distinguisher 2500:10001;
        l2vpn-id l2vpn-id:2500:100;
        vrf-target target:2500:1001;
        protocols {
            vpls {
                no-tunnel-services;
            }
        }
    }                                   
    vpls-500 {
        instance-type vpls;
        interface ge-0/0/9.500;
        protocols {
            vpls {
                no-tunnel-services;
                vpls-id 500;
                mac-flush;
                neighbor 192.168.0.2 {
                    pseudowire-status-tlv;
                }
                neighbor 192.168.0.7 {
                    pseudowire-status-tlv;
                }
            }
        }
    }
}
system {
    host-name RT.SPB.K12;
    root-authentication {
        encrypted-password "$1$yjZyno7x$gXQzjRxiaQILDLVjJ2eqz1"; ## SECRET-DATA
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family inet {
                address 10.0.0.18/31;
            }
            family iso;
            family mpls;
        }
    }
    ge-0/0/2 {
        unit 0 {
            family inet {
                address 10.0.0.3/31;
            }
            family iso;                 
            family mpls;
        }
    }
    ge-0/0/9 {
        flexible-vlan-tagging;
        native-vlan-id 4094;
        encapsulation flexible-ethernet-services;
        unit 100 {
            vlan-id 4094;
            family inet {
                address 172.16.0.3/31;
            }
        }
        unit 250 {
            encapsulation vlan-vpls;
            vlan-id 250;
            family vpls;
        }
        unit 500 {
            encapsulation vlan-vpls;
            vlan-id 500;
            family vpls;
        }                               
        unit 2500 {
            encapsulation vlan-vpls;
            vlan-id 2500;
            family vpls;
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 192.168.0.7/32;
            }
            family iso {
                address 49.0001.1921.6800.0007.00;
            }
        }
    }
}
routing-options {
    router-id 192.168.0.7;
    autonomous-system 250;
}
protocols {
    rsvp {                              
        interface all;
    }
    mpls {
        interface all;
    }
    bgp {
        group iBGP {
            type internal;
            local-address 192.168.0.7;
            family inet {
                any;
            }
            family inet-vpn {
                unicast;
            }
            family l2vpn {
                auto-discovery-only;
                signaling;
            }
            neighbor 192.168.0.4;
            neighbor 192.168.0.5;
        }
    }                                   
    isis {
        level 1 disable;
        interface ge-0/0/0.0 {
            point-to-point;
        }
        interface ge-0/0/2.0 {
            point-to-point;
        }
        interface lo0.0;
    }
    ldp {
        interface all;
    }
}
policy-options {
    policy-statement L3VPN_BGP-OSPF {
        from protocol bgp;
        then accept;
    }
}
routing-instances {
    L3VPN {
        instance-type vrf;              
        interface ge-0/0/9.100;
        route-distinguisher 250:0;
        vrf-target {
            import target:250:500;
            export target:250:500;
        }
        vrf-table-label;
        protocols {
            ospf {
                export L3VPN_BGP-OSPF;
                area 0.0.0.0 {
                    interface ge-0/0/9.100 {
                        interface-type p2p;
                    }
                }
            }
        }
    }
    kompella-vpls-250 {
        instance-type vpls;
        interface ge-0/0/9.250;
        route-distinguisher 10.250.0.2:1;
        vrf-target target:250:250;      
        protocols {
            vpls {
                no-tunnel-services;
                site Sites {
                    site-identifier 2;
                    interface ge-0/0/9.250;
                }
                mac-flush;
            }
        }
    }
    martini-auto {
        instance-type vpls;
        interface ge-0/0/9.2500;
        route-distinguisher 2500:10001;
        l2vpn-id l2vpn-id:2500:100;
        vrf-target target:2500:1001;
        protocols {
            vpls {
                no-tunnel-services;
            }
        }
    }                                   
    vpls-500 {
        instance-type vpls;
        interface ge-0/0/9.500;
        protocols {
            vpls {
                no-tunnel-services;
                vpls-id 500;
                mac-flush;
                neighbor 192.168.0.2 {
                    pseudowire-status-tlv;
                }
                neighbor 192.168.0.6 {
                    pseudowire-status-tlv;
                }
            }
        }
    }
}
system {
    host-name RT.SPB.LNX;
    root-authentication {
        encrypted-password "$1$yjZyno7x$gXQzjRxiaQILDLVjJ2eqz1"; ## SECRET-DATA
    }
}
interfaces {
    ge-0/0/0 {
        flexible-vlan-tagging;
        native-vlan-id 4094;
        encapsulation flexible-ethernet-services;
        unit 0 {
            vlan-id 4094;
            family inet {
                address 10.0.0.19/31;
            }
            family iso;
            family mpls;
        }
    }
    ge-0/0/1 {
        flexible-vlan-tagging;          
        native-vlan-id 4094;
        encapsulation flexible-ethernet-services;
        unit 0 {
            vlan-id 4094;
            family inet {
                address 10.0.0.27/31;
            }
            family iso;
            family mpls;
        }
    }
    ge-0/0/2 {
        flexible-vlan-tagging;
        native-vlan-id 4094;
        encapsulation flexible-ethernet-services;
        unit 0 {
            vlan-id 4094;
            family inet {
                address 10.0.0.23/31;
            }
            family iso;
            family mpls;
        }                               
    }
    ge-0/0/3 {
        flexible-vlan-tagging;
        native-vlan-id 4094;
        encapsulation flexible-ethernet-services;
        unit 0 {
            vlan-id 4094;
            family inet {
                address 60.0.0.1/31;
            }
        }
        unit 500 {
            encapsulation vlan-ccc;
            vlan-id 500;
            family ccc;
        }
    }
    ge-0/0/4 {
        flexible-vlan-tagging;
        native-vlan-id 4094;
        encapsulation flexible-ethernet-services;
        unit 0 {
            vlan-id 4094;               
            family inet {
                address 10.0.0.9/31;
            }
            family iso;
            family mpls;
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 192.168.0.8/32;
            }
            family iso {
                address 49.0001.1921.6800.0008.00;
            }
            family mpls;
        }
    }
}
routing-options {
    static {
        route 192.168.0.1/32 {
            static-lsp-next-hop LNX-M34;
        }
    }
    router-id 192.168.0.8;
    autonomous-system 250;
}
protocols {
    rsvp {
        interface all;
    }
    mpls {
        interface all;
    }
    bgp {
        export export-BGP;
        group eBGP {
            type external;
            neighbor 60.0.0.0 {
                peer-as 600;
            }
        }
        group iBGP {
            type internal;
            local-address 192.168.0.8;  
            family inet {
                any;
            }
            family inet-vpn {
                unicast;
            }
            family l2vpn {
                auto-discovery-only;
                signaling;
            }
            export Next-Hop-Self;
            neighbor 192.168.0.4;
            neighbor 192.168.0.5;
        }
    }
    isis {
        level 1 disable;
        interface ge-0/0/0.0 {
            point-to-point;
        }
        interface ge-0/0/1.0 {
            point-to-point;
        }                               
        interface ge-0/0/2.0 {
            point-to-point;
        }
        interface ge-0/0/4.0 {
            point-to-point;
        }
        interface lo0.0;
    }
    ldp {
        interface all;
    }
    l2circuit {
        neighbor 192.168.0.1 {
            interface ge-0/0/3.500 {
                virtual-circuit-id 1488;
            }
        }
    }
}
policy-options {
    policy-statement Next-Hop-Self {
        from protocol bgp;
        then {                          
            next-hop self;
        }
    }
    policy-statement export-BGP {
        term Aggregate {
            from {
                protocol aggregate;
                route-filter 250.0.0.0/16 exact;
            }
            then accept;
        }
        term BGP {
            from protocol bgp;
            then accept;
        }
        then reject;
    }
}
PreviousL2/L3 VPNNextПолезные ссылки

Last updated 4 years ago

Was this helpful?